Network Status
Subscribe
to updates
Inbound Call Failures
Major incident
Services Overview
GoVoIP
Hosted 3CX
2023-01-14 07:27 NZDT
· 6 minutes
Updates
Resolved
Issue has been resolved
January 14, 2023 · 07:34 NZDT
Issue
Inbound calls are currently failing. We are working on the issue.
January 14, 2023 · 07:28 NZDT
← Back