Northpower Fibre Issues

Minor incident Broadband North Island Whangarei UFB (Northpower)
2024-09-06 08:19 NZST · 19 minutes

Updates

Resolved

Issue has now been resolved. If you are still having internet issues, please let us know.

September 6, 2024 · 08:38 NZST
Issue

Customers in Whangarei using Northpower Fibre are experiencing connection issues, we are investigating the cause.

September 6, 2024 · 08:19 NZST

← Back