Tuatahi First Fibre Tauranga - Broadband Outage

Major incident Broadband North Island Tauranga/Bay of Plenty UFB (Tuatahi First Fibre)
2024-09-18 07:48 NZST · 45 minutes

Updates

Resolved

Fault has been Identified and Resolved.
All Tauranga region customers should now be back online.

If you are experiencing any issues still, please contact our support desk.

September 18, 2024 · 08:32 NZST
Issue

We are investigating an issue affecting broadband on Tuatahi First Fibre connections in Tauranga. Will provide updates when available.

September 18, 2024 · 08:05 NZST

← Back